Back to top

Set Software enable to true, Ethernet connection is cut off.

0 votes
+ vote
Vote up!

Hello.

In Workbench, if I set Software enable to true during setting the Setup wizard, there is a problem that the Ethernet connection is cut off.

Once the connection is lost, the following dialog will be displayed and I will not be able to reconnect unless I restart the servo.

Failed to get physical device compatibility information.
Your device cannot be reached, please check your connection information.

The environment is as follows.

Servo: ADK-P00306-NBEC-0000
Encoder: RCN8510 667593-10
Motor: KBM-57S01-C00

The AKD servo itself displays the IP by plugging and unplugging the Ethernet cable, so it doesn't seem to hang.
Also, Device Status is all true except Software Enable (and Dynamic Brake).


Can you give me a solution to this problem?

Thank you.

Comments

If the IP address is changing, you can assign the AKD drive a "fixed" IP address.

If the EC field bus is disconnected, the drive is expecting ALL software enable commands to be received via the EC network. This CAN BE bypassed, but if this is done, the drive will ALWAYS DEFAULT to having the SW enable "on" every time the drive powers up. How to accomplish this is documented here in KDN at: https://www.kollmorgen.com/en-us/developer-network/akd-and-software-enab...

Michael Brown_455 - Tue, 10/12/2021 - 12:59
Log in or register to post comments

No answers have been submitted for this question.

ANSWER THIS QUESTION
You may login with either your assigned username or your e-mail address.
The password field is case sensitive.

If you do not have an account, click here to register.